Secciones

Entradas del blog


Instalar XAMPP 8.1.6 | Fedora 36

2 comentarios

XAMPP es una distribución de Apache completamente gratuita y fácil de instalar que contiene MariaDB, PHP y Perl. El paquete de instalación de XAMPP ha sido diseñado para ser increíblemente fácil de instalar y usar.

Es la mejor opción para iniciarse en el desarrollo web con php, bases de datos, etc, en su lugar pueden utilizar otras opción, al final de cuentas, sólo es eso, opciones.

Descargar XAMPP

https://www.apachefriends.org/download.html

Instalar dependencia

sudo dnf install libnsl mod_perl libaio

Asignar permisos y ejecución

chmod u+x xampp-linux-x64-8.1.6-0-installer.run
sudo ./xampp-linux-x64-8.1.6-0-installer.run

Instalar XAMPP

Iniciando instalación
Seleccionando módulos de instalación
Iniciando instalación
Instalando XAMPP
Finalizando instalación

Al finalizar la instalación se lanzará el módulo de administración, si por alguna razón no se inician los servicios, revisar la pestaña de <Application log> para ver los errores:

Errores comunes y configuración

Cuando es una actualización o instalación desde cero, es necesario realizar algunas configuraciones:

1.- Asignar frase secreta y ruta de la carpeta temporal

Abrir el archivo config.inc.php

sudo gedit /opt/lampp/phpmyadmin/config.inc.php

En la imagen de abajo se muestra un ejemplo de cómo debe quedar el archivo configurado, se usar una frase de 32 caracteres, y además, agregar la línea de código siguiente:

$cfg['TempDir'] = '../temp/';

2.- Error modulo perl

En algunos casos marca el siguiente error:

Ésto se debe a que se debe instalar las librerías y paquetes de perl:

sudo dnf install libnsl mod_perl
cd /lib64
sudo ln -s libnsl.so.2 libnsl.so.1
sudo ln -s libnsl.so.1 libnsl.so

3.- Error de upgrade_mysql

Este error es porque se requiere actualizar la compatibilidad de mariadb con las funciones de mysql.

Abrir la terminal, ir al directorio:

cd /opt/lampp/bin/

Una vez ahí, ejecutar el comando:

sudo ./mysql_upgrade

Suponiendo que usen contraseña para la ejecución de xampp, entonces es necesario especificar el usuario y la contraseña

sudo ./mysql_upgrade -uuser -ppassword

Ejecutar el comando, y listo

Imagen 3

4.- Error de librerías de libc.so.6 y libdl.so.2

Se soluciona comentando la línea que dice #export LD_ASSUME_KERNEL=2.2.5 y descomentar la línea echo "XAMPP: DISABLE PNTL..." del ejecutable de la ruta: sudo gedit /opt/lamp/lamp

sudo gedit /opt/lampp/lampp

5.- Error de puerto con dropbox

Dropbox y xampp utilizan un puerto en común, el 443, así que es necesario reemplazar dicho puerto, por otro, por ejemplo 4433, en los siguientes archivos:

sudo gedit /opt/lampp/xampp
sudo gedit /opt/lampp/etc/extra/httpd-ssl.conf

Una vez realizado el cambio, reiniciar el servicio de xampp

sudo /opt/lampp/lampp start

6.- Restaurar base de datos de archivos de más 40MB

Por defecto permite subir archivos hasta 40mb, sin embargo, ésto se puede modificar configurando el archivo php.ini:

sudo gedit /opt/lampp/etc/php.ini

Buscar las siguientes líneas y modificarlas a la cantidad de acuerdo a lo que se requiere.

; http://php.net/post-max-size
post_max_size=40M

[...]

; http://php.net/upload-max-filesize
upload_max_filesize=40M

6.- Desinstalar XAMPP

La desinstalación de xampp, previamente sugiero que realicen respaldo de sus bases de datos, e información de sitios desarrollado.

Una vez estar seguros de realizar la desinstalación, abrir la terminal, y entrar a la siguiente ruta:

cd /opt/lampp/

Ejecutar el siguiente comando:

sudo ./uninstall

Inmediatamente se iniciará un asistente de desinstalación, clic en Ok, aceptar, siguiente, y listo.

Y con ésto finaliza mi tutorial, muchas gracias por leer.

Comentarios:

  • Buenas noches muy interesante, pero no logro pasar del primer paso de dar los permisos, ejecuto esa linea de comandos y la de instalaccion y me muestra el icono del setup en la barra de menu pero no me muestra ni abre pantalla
    • Fernando Merino
      hace 3 meses
      Qué tal, ese error es bastante raro. Tengo la siguientes posibles razones: 1.- A lo mejor estás usando wayland y tal vez no lo soporte, o bien, no tienes actualizados los paquetes para los gráficos, intenta pasarlo a XORG y revisa y si funciona. 2.- Si no estás usando fedora con gnome, entonces podría ser ese el problema, aunque ya he utilziando endearvous, manjaro, con gnome obviamente, por lo que no debería ocurri eso 3.- No olvides instalar las dependencias previas
Entradas del blog
Redes sociales
Accesos directos